Warning: Parameter 1 to SyntaxHighlight_GeSHi::configureParser() expected to be a reference, value given in /var/www/vhosts/rave.gatech.edu/httpdocs/help/includes/Hooks.php on line 207

Warning: Parameter 1 to SyntaxHighlight_GeSHi::resourceLoaderRegisterModules() expected to be a reference, value given in /var/www/vhosts/rave.gatech.edu/httpdocs/help/includes/Hooks.php on line 207
Difference between revisions of "Workspace objects" - Rave Documentation

Difference between revisions of "Workspace objects"

From Rave Documentation
Jump to: navigation, search
m (Admin moved page Workspace Objects to Workspace objects)
Line 1: Line 1:
 
=Introduction=
 
=Introduction=
 +
A "workspace object" refers to any of the visualizations, tables, or controls that you can place on [[the workspace]] by clicking the "Create New..." button on the [[Manage tab]].
  
 +
==Selecting a workspace object==
 +
Most of the time one workspace object is selected, which is denoted by that object having a colored border and a same-color shading in the Navigator. Occasionally, no workspace object is selected. In no case can two [[workspace objects]] be selected at the same time: there is always at most one currently selected object.
  
 +
To select a workspace object, simply click in the area around its edges, i.e. the region around the object that is (usually) the same color as [[the workspace]] background, that obscures [[the workspace]] gridlines. The exact region that needs to be clicked varies for each object, but you'll get the hang of it quickly. In general, clicking within a graph or table causes some action other than selecting [[the workspace]] object, which is why you need to click around their edge instead. For [[workspace objects]] that have no interactive clickable components, you can click anywhere on the object to select it.
  
=Java Workspace Objects=
+
Selecting a workspace object has the following effects:
'''Note:''' This information concerns future Rave versions. Your version of Rave has no Java workspace objects, so just ignore this section.
+
*The [[View tab]], [[Format tab]], and [[Specialize tab]] update to let you control the currently selected workspace object.
 +
*All the buttons on the [[Manage tab]] under the "Workspace" heading refer to the currently selected workspace object (except "Create New," which makes a new object, and "Restore", which restores a previously put-away object.)
 +
*The controls on the [[Export tab]] are used to save/export the currently selected workspace object.
 +
*Optimizer animations are shown on the currently selected workspace object.
 +
*Any other Rave action that references the "current graph" or "current workspace object" refers to the currently selected workspace object.  
  
Some workspace objects are labeled with "Java" in their name. This indicates that these workspace objects are not made using the normal MATLAB plotting capabilities, but rely on java swing components instead. These workspace objects provide special capabilities that would be impossible to implement with normal MATLAB graphics objects (such as the Java M Code Editor) or that are substantially faster than the normal MATLAB implementation (such as the Java Data Table).
 
  
Unfortunately because of a fundamental limitation in MATLAB figure windows, it is impossible to display java objects behind normal MATLAB graphics objects; the java objects are always on top. Consequently, it is impossible to allow java objects to scroll behind the Rave interface the way normal graphs do. Currently the workaround we use for this is that java workspace objects are only visible when they the workspace is scrolled such that the entire java object is visible on screen. If any part of the java object extends beyond the visible portion of the workspace, the entire object will disappear and you will see a messsage in its place telling you to scroll the workspace in order to use the java object. Obviously this isnt a very elegant solution, but we figure it's better to give you the option of using these java controls than to just leave them out of Rave entirely.
+
==Java Workspace Objects==
 +
'''Note:''' This information concerns future Rave versions. Your version of Rave has no Java [[workspace objects]], so just ignore this section.
 +
 
 +
Some [[workspace objects]] are labeled with "Java" in their name. This indicates that these [[workspace objects]] are not made using the normal MATLAB plotting capabilities, but rely on java swing components instead. These [[workspace objects]] provide special capabilities that would be impossible to implement with normal MATLAB graphics objects (such as the Java M Code Editor) or that are substantially faster than the normal MATLAB implementation (such as the Java Data Table).
 +
 
 +
Unfortunately because of a fundamental limitation in MATLAB figure windows, it is impossible to display java objects behind normal MATLAB graphics objects; the java objects are always on top. Consequently, it is impossible to allow java objects to scroll behind the Rave interface the way normal graphs do. Currently the workaround we use for this is that java [[workspace objects]] are only visible when they [[the workspace]] is scrolled such that the entire java object is visible on screen. If any part of the java object extends beyond the visible portion of [[the workspace]], the entire object will disappear and you will see a messsage in its place telling you to scroll [[the workspace]] in order to use the java object. Obviously this isnt a very elegant solution, but we figure it's better to give you the option of using these java controls than to just leave them out of Rave entirely.

Revision as of 15:01, 9 January 2015

Introduction

A "workspace object" refers to any of the visualizations, tables, or controls that you can place on the workspace by clicking the "Create New..." button on the Manage tab.

Selecting a workspace object

Most of the time one workspace object is selected, which is denoted by that object having a colored border and a same-color shading in the Navigator. Occasionally, no workspace object is selected. In no case can two workspace objects be selected at the same time: there is always at most one currently selected object.

To select a workspace object, simply click in the area around its edges, i.e. the region around the object that is (usually) the same color as the workspace background, that obscures the workspace gridlines. The exact region that needs to be clicked varies for each object, but you'll get the hang of it quickly. In general, clicking within a graph or table causes some action other than selecting the workspace object, which is why you need to click around their edge instead. For workspace objects that have no interactive clickable components, you can click anywhere on the object to select it.

Selecting a workspace object has the following effects:

  • The View tab, Format tab, and Specialize tab update to let you control the currently selected workspace object.
  • All the buttons on the Manage tab under the "Workspace" heading refer to the currently selected workspace object (except "Create New," which makes a new object, and "Restore", which restores a previously put-away object.)
  • The controls on the Export tab are used to save/export the currently selected workspace object.
  • Optimizer animations are shown on the currently selected workspace object.
  • Any other Rave action that references the "current graph" or "current workspace object" refers to the currently selected workspace object.


Java Workspace Objects

Note: This information concerns future Rave versions. Your version of Rave has no Java workspace objects, so just ignore this section.

Some workspace objects are labeled with "Java" in their name. This indicates that these workspace objects are not made using the normal MATLAB plotting capabilities, but rely on java swing components instead. These workspace objects provide special capabilities that would be impossible to implement with normal MATLAB graphics objects (such as the Java M Code Editor) or that are substantially faster than the normal MATLAB implementation (such as the Java Data Table).

Unfortunately because of a fundamental limitation in MATLAB figure windows, it is impossible to display java objects behind normal MATLAB graphics objects; the java objects are always on top. Consequently, it is impossible to allow java objects to scroll behind the Rave interface the way normal graphs do. Currently the workaround we use for this is that java workspace objects are only visible when they the workspace is scrolled such that the entire java object is visible on screen. If any part of the java object extends beyond the visible portion of the workspace, the entire object will disappear and you will see a messsage in its place telling you to scroll the workspace in order to use the java object. Obviously this isnt a very elegant solution, but we figure it's better to give you the option of using these java controls than to just leave them out of Rave entirely.