Warning: Parameter 1 to SyntaxHighlight_GeSHi::configureParser() expected to be a reference, value given in /var/www/vhosts/rave.gatech.edu/httpdocs/help/includes/Hooks.php on line 207

Warning: Parameter 1 to SyntaxHighlight_GeSHi::resourceLoaderRegisterModules() expected to be a reference, value given in /var/www/vhosts/rave.gatech.edu/httpdocs/help/includes/Hooks.php on line 207
System requirements - Rave Documentation

System requirements

From Rave Documentation
Revision as of 00:37, 13 November 2011 by Matt (Talk | contribs) (Created page with "==Software requirements== Most importantly, Rave requires that you have MATLAB. Currently, all Rave features are supported on MATLAB releases 2009a and later. Rave will run on re...")

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

Software requirements

Most importantly, Rave requires that you have MATLAB. Currently, all Rave features are supported on MATLAB releases 2009a and later. Rave will run on releases as old as 2007b, but some features do not work on older versions. (We do not extensively test RAVE on older version of MATLAB. If you find a bug when using an older version, tell us about it.) Certain features of RAVE, including some optimizers, require additional MATLAB toolboxes.

Rave has only been tested on 32-bit Windows XP and Windows 7. All features of RAVE except the multiobjective optimizers should work on 64-bit MATLAB installations. We believe RAVE will also work on current Mac operating systems, but we have not tested it.

Hardware requirements

If your computer can run MATLAB, it can run Rave. But for good performance, we recommend:

  • Vertical screen resolution of at least 900 pixels (Rave may or may not display correctly on smaller displays, depending on how small they are).
  • Dual-core, 2Ghz processor (recommended)
  • 2Gb RAM (recommended)
  • Non-Integrated graphics (recommended)

The speed of Rave's computations will be directly related to your processor speed, and the speed of display updates and animations will be more closely related to your graphics card.